Either all Options must start with + or -, or no Option may Apache


After upgrading Apache 2.2 to 2.4 following Apache Error occurred : Either all Options must start with + or -, or no Option may

Apache Error Message:

Ignoring deprecated use of Default Type in line
AH00526: Syntax error on line xxx of /etc/httpd/conf/httpd.conf:
Either all Options must start with + or -, or no Option may.

Solution

Either you have to use +,- in the options or don’t use any options.
Mixing “No Option” and , “-” not allowed


Allowed Options in Apache Config

Options -Indexes +FollowSymLinks

Options +Indexes +FollowSymLinks -MultiViews

Options Indexes FollowSymLinks MultiViews

Not Allowed Options:

Options -Indexes FollowSymLinks

Options  Indexes +FollowSymLinks -MultiViews