Bugzilla htaccess ExpiresActive not allowed here, Internal Server Error 500


After Upgrading Bugzilla, Apache server says htaccess ExpiresActive not allowed here

Internal Server Error 500

After Upgrading the Bugzilla form 3.xx to 4.xx, following error occurred while browsing.

Error Message:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@datapatterns.co.in and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apahce Httpd  error log shows the following error

#tail -f  /var/log/httpd/error_log

/usr/share/bugzilla/.htaccess: ExpiresActive not allowed here

Then I checked the Bugzilla setup for errors.
Go to Bugzilla installation directory
#cd /usr/share/bugzilla
./checksetup.pl
No error found.

Solution:

Modify the htaccess file as shown below.
(Hide other parameters)
#vim /usr/share/bugzilla/.htaccess

<FilesMatch ^(.*.pm|.*.pl|.*localconfig.*)$>
   deny from all
 </FilesMatch>

If bugzilla web service is configured in httpd.conf you can remove the .htaccess file
#cd /usr/share/bugzilla
#mv .htaccess .htaccess.bk
reboot the Apache server
#service httpd restart

Now the error message is gone.

Apache Config File Example for Bugzilla:

<VirtualHost serverip:*>
DocumentRoot /usr/share/bugzilla
ServerName bugzilla.domain.com
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
IndexOptions SuppressColumnSorting SuppressDescription SuppressHTMLPreamble SuppressLastModified SuppressSize SuppressIcon SuppressRules
Options +ExecCGI
<Directory "/usr/share/bugzilla">
        AddHandler cgi-script .cgi
        Options -Indexes +ExecCGI
DirectoryIndex index.cgi
        AllowOverride Limit

</Directory>
<FilesMatch ^(.*.pm|.*.pl|.*localconfig.*)$>
   deny from all
 </FilesMatch> 
</VirtualHost>